В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
muradir1102
muradir1102
20.03.2021 01:25 •  Информатика

Нужно написать программу на языке с++ которая должна:
проверить трехзначное число на четность и найти сумму его цифр, если число четное, или произведение его цифр, если число нечетное.

Ответ:
Денок07
Денок07
10.10.2020 16:24

#include <iostream>

using namespace std;

int main()

{

   int n;

   cin >> n;

   n = abs(n); // если введут отрицательное

   if(n > 99 && n < 1000)

   {

       int d1, d10, d100;

       d1 = n % 10;

       d100 = n / 100;

       d10 = n / 10 % 10;

       int r;

       if(n % 2 == 0)

           r = d100 + d10 + d1;

       else

           r = d100 * d10 * d1;

       cout << r;

   }

   else

       cout << "Число не трехзначное";

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?