В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
килр
килр
12.05.2022 21:31 •  Информатика

Одномерный массив содержит 100 элементов случайных целых чисел от 20 до 100. нужно написать программу вывода на экран этих чисел и найти сумму массива с 20 по 60 элемент.
программу нужно писать в паскале(pascalabc).

Ответ:
ДанилЮсупов
ДанилЮсупов
10.10.2020 15:31

var a:array [1..100] of Integer;

i,s:Integer;

begin

write ('Массив ');

for i:=1 to 100 do

begin

a[i]:=random(81)+20;

write (a[i]:3);

if (i>=20) and (i<=60) then s:=s+a[i]

end;

writeln;

write ('Сумма ',s)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?