В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lyazzat260703
lyazzat260703
15.01.2022 21:14 •  Информатика

Составить программу по вычислению функции в turbp pascal
на скриншоте

текст программы может выглядеть следующим образом:
program lab_2-1;
uses crt; { раздел объявления внешних модулей }
label m1,m2;
var
n : integer;
x,y : real;
p: byte; {признак выполнения пунктаn1}
begin
clrscr; { очистка экрана }
riteln(‘программа вычисления функции…’);

{ вывод на экран меню }
writeln(‘++’);
writeln(‘| 1. ввод данных |’);
writeln(‘| 2. вычисление функции и вывод результатов |’);
writeln(‘| 3. завершение работы программы |’);
writeln(‘++’);
p: =0;
m1: riteln(‘введите пункт меню’);
readln(n); { ввод номера пункта меню}
case n of
1: begin { ввод данных }
m2: write(‘введите значение аргумента x=’);
readln(x)

{ проверка допустимого значения аргумента }
if x=0 then begin
riteln(‘x не может быть равным 0 по условию’) ;
goto m2; end;
p: =1; {пункт n1 выполнен}
end;
2: { вычисление значения функции }
begin
if p< > 0 then
writeln (‘данные не введены, выполните пункт n1’);
else
begin
{ операторы вычисления и вывода значения функции }
if x> 0 then y: =1/x else y: =x*x;
writeln(‘при х=’, x: 7: 2, ‘ y=’, y: 7: 2)
end;
end;
3: exit { выход из программы }
end; { end case }
goto m1;
end. { конец программы}

Ответ:
Olegggg04
Olegggg04
11.09.2020 13:58

User CRT;

Var x, y:real;

BEGIN

ClrScr;

Write('Введите значение функции x=');

ReadLn(x);

if x<0 then y:=x*x+4*x-8 else y:=1/(x*x+4*x-8);

WriteLn('при x=', x:7:2, 'y =', y:7:2);

END.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?