В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
aliyenneqi
aliyenneqi
13.12.2020 13:21 •  Информатика

Дано натуральное число составить программу которая определяет сумму кубов его цифр с++

Ответ:
DetaRUSION
DetaRUSION
10.10.2020 15:11

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

   int n, s = 0;

   cin >> n;

   while (n > 0)

   {

       s += pow(n % 10, 3);

       n = n / 10;

   }

   cout << s;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?