В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
petrius100p0bmz5
petrius100p0bmz5
12.06.2020 02:10 •  Информатика

Язык программирования pascal

дано число ch в десятичной системе исчисления. написать программу, которая переводит число в систему исчисления с основанкм m.

технічні умови: программа читает с клавиатуры в первой строке число m (2≤m≤16) , во второй - число ch (0≤ch≤2+109) . программа выводит на экран ответ в виде текстовой строки.

пример:

ввод:

16

1024

вывод:

400

я то программу сделал, она работает(вроде), но на сайте для проверки пишет что не все значения подходят сделать с нуля программу(я сам найду у себя ошибку) или указать в каком месте я ошибся.

моё решение на фото.

Ответ:
kopalkina02
kopalkina02
10.10.2020 13:31

const s:string='0123456789ABCDEF';//цифры СС

var n,m,ch:integer;

r:string;

begin

write('Введите число в 10 СС: ');

readln(ch);

write('Введите СС: ');

readln(m);

write('В ',m,' CC число ',ch);

if ch=0 then r:='0' else r:='';

while ch>0 do

begin

r:=s[ch mod m + 1]+r;//берем остаток от деления на CC и эту цифру пишем в начало строки

ch:=ch div m;//берем целое от деления на CC

end;

write(' равно ',r)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?