В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
skipos
skipos
13.06.2021 18:23 •  Информатика

Написать программу которая сортирует одномерный массив "методом простого выбора" в порядке возрастания на с++

Ответ:
roman2223q
roman2223q
10.10.2020 13:20

#include <iostream>

#include <iomanip>

using namespace std;

int main()

{

   int n;

   cin >> n;

   int a[n];

   srand(time(0));

   for(int i=0; i<n; i++)

   {

       a[i]=-99+rand()%199;

       cout << setw(4) <<a[i];

   }

   cout << endl;

   int j=n-1;

   while(j>0)

   {

       int mx=a[0], imx=0;

       for(int i=1; i<=j; i++)

           if(a[i]>mx)

           {

               mx=a[i];

               imx=i;

           }

       a[imx]=a[j];

       a[j]=mx;

       j--;

   }    

   for(int i=0; i<n; i++)

       cout << setw(4) <<a[i];

    return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?