В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
chukalina
chukalina
01.06.2020 16:28 •  Информатика

Написать программу в паскаль турбо

дан массив a размерностью n (размерность вводит пользователь). массив заполнен случайными числами от -15 до 15. каждый второй элемент заменить на результат их деления на предыдущий элемент (округлить до 2 знаков после запятой).

Ответ:
Durban1984
Durban1984
10.10.2020 13:10

program gam;

const

 nn = 100;

var

 a: array[1..nn] of real;

 i, n: integer;

 r: real;

begin

 read(n);

 randomize;

 for i := 1 to n do

 begin

   a[i] := (random(3001) - 1500) / 100;

   write(a[i]:7:2);

 end;

 writeln;

 i := 2;

 while i <= n do

 begin

   a[i] := a[i - 1] / a[i];

   i := i + 2

 end;

 for i := 1 to n do

   write(a[i]:7:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?