В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ZHANSAYA20061
ZHANSAYA20061
17.04.2020 03:45 •  Информатика

1) напишите программу, которая организует массив из 10 целых чисел по случайному закону в интервале от 0 до 200. и определяет сумму элементов массива кратных 5. на экран выводятся элементы созданного массива в строку с форматом 4, элементы , значение которых кратно 5 и сумма. используйте 2 цикла.

Ответ:
issirisoyf2q6
issirisoyf2q6
10.10.2020 13:18

var

 a: array [1..10] of Integer;

 i, s: Integer;

begin

 Randomize;

 s := 0;

 for i := Low (a) to High (a) do begin

   a [i] := Random (201);

   Write (a [i] :4);

 end;

 WriteLn;

 for i := Low (a) to High (a) do begin

   if a [i] mod 5 = 0 then begin

     s := s + a [i];

     Write (a [i] :4);

   end;

 end;

 WriteLn;

 WriteLn ('Сумма = ', s);

 ReadLn;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?