В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kateadel01
kateadel01
24.12.2021 07:25 •  Информатика

Составьте программу к .дано натуральное число n.требуется найти его наименьшую цифру.​

Ответ:
xach5
xach5
10.10.2020 13:06

var

 n, d, min: integer;

begin

 read(n);

 n := abs(n); // Если введено отрицательное

 min := 10;

 while n > 0 do

 begin

   d := n mod 10;

   n := n div 10;

   if d < min then

     min := d;

 end;

 write(min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?