В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Anush8383
Anush8383
13.04.2023 13:36 •  Информатика

Нужно составить программу pascal, в которой вводятся интервалы двух отрезков и число х. программа должна определять какому отрезку принадлежит это число. без использования and и or​

Ответ:
Алена173
Алена173
05.05.2020 14:59

Объяснение:

program kek;

var

 l1, r1, l2, r2, x: Integer;

begin

 read(l1, r1, l2, r2, x);

 if ((x-l1)*(r1-x) >= 0) then writeln('Первый отрезок.');

 if ((x-l2)*(r2-x) >= 0) then writeln('Второй отрезок.');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?