В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Krst263
Krst263
07.04.2022 17:04 •  Информатика

Много !
как в паскале написать программу:
вывести первые n степеней числа 2, начиная с нулевой. найти сумму цифр введенного числа.

Ответ:
nvanislavskaya
nvanislavskaya
10.10.2020 11:46

var a,b,c,d:integer;

begin

writeln('введите число'); //запрос числа

readln(a);

d:=a;                 //это для красоты

while (a<>0) do begin //пока мы не дойдём до последней цифры в числе делать следующее

 b:=a mod 10;        //берём последнюю цифру числа  

 c:=c+b;             //находим сумму цифр

 a:=a div 10;        //убираем из данного числа последнюю цифру

 end;

 writeln('сумма цифр числа ',d,' = ',c); // вывод результата

end.

Вроде вот)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?