В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
DuRaDoN2017
DuRaDoN2017
11.07.2020 09:57 •  Информатика

Составить программу, определяющую, попадает ли точка с заданными координатами x и y в закрашенную область (использовать формулы уравнения прямой, проходящей через две точки, уравнения окружности, уравнения прямых, параллельных осям координат). результат работы программы вывести в виде текстового сообщения. (параметры r, r1, r2, a, b,с вводятся с клавиатуры.) - если имеются

Ответ:
Alisa27Alisa
Alisa27Alisa
11.08.2020 17:52

отправь нарушение ошипся я не знаю

0,0(0 оценок)
Ответ:
raminowka
raminowka
11.08.2020 17:52

var

 x, y, r: real;

begin

 read(x, y, R);

 if (x * x + y * y <= R * R) or

   (y <= 0) and (y >= -2 * x) and (y >= 2 * (x - R)) then

   write('попадает')

 else

   write('не попадает');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?