В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sdfdsgdfh
sdfdsgdfh
05.04.2020 07:31 •  Информатика

Составить программу на паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив. для определения максимального элемента в строке использовать function ,а для ввода и вывода массивов - procedure

Ответ:
adubnovitskaj
adubnovitskaj
10.10.2020 11:37

function MaxElem(a: array[,] of integer; i: integer): integer;

var

 j, m: integer;

begin

 m := a[i, 0];

 for j := 1 to length(a, 1) - 1 do

   if a[i, j] > m then

     m := a[i, j];

 MaxElem := m

end;

procedure Input(var a: array[,] of integer);

var

 i, j: integer;

begin

 Writeln('вводите элементы массива');

 for i := 0 to length(a, 0) - 1 do

   for j := 0 to length(a, 1) - 1 do

     read(a[i, j]);

end;

procedure Output(var a: array of integer);

var

 i: integer;

begin

 Writeln('полученный массив');

 for i := 0 to length(a) - 1 do

   write(a[i], ' ');

end;

var

 m, n, i: integer;

 a: array[,] of integer;

 b: array of integer;

begin

 read(m, n); // ввод числа строк и столбцов

 setlength(a, m, n);

 setlength(b, m);

 Input(a);

 for i := 0 to m - 1 do

   b[i] := MaxElem(a, i);

 Output(b);

end.

Написано на Free Pascal

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?