В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
leralera31051
leralera31051
06.08.2020 16:13 •  Информатика

Решить в питоне (python) всего 1 15 !
надо написать программу, которая принимает текст и выводит два слова: наиболее часто встречающееся и самое длинное. без import.

если ответите.

Ответ:
mauzeriss
mauzeriss
10.10.2020 10:28

n = input()

n=n.replace("."," ")

n=n.replace(","," ")

n=n.replace("!"," ")

n=n.replace("?"," ")

n=n.replace("-"," ")

n=n.replace("("," ")

n=n.replace(")"," ")

n = n.split()

maxlength = ""

maxcount  = ""

for a in range(len(n)):

   if len(n[a])>len(maxlength):

       maxlength = n[a]

   if n.count(n[a])>len(maxcount):

       maxcount = n[a]

 

print("maxcount: "+maxcount)

print("maxlength: "+maxlength)

Объяснение:

str.replace(old,new) = заменяет old_word на new_word (чтобы очищать от . , ! ? ( ) -символов(ещё есть другие но эти основные(можешь просто копировать вставить заменить на другие))

str.split() = разделяет строку по пробелам

array.count()=считает количество строк в данном массиве

len(array) = дает длину массива

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?