В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
maksimkakravchenko
maksimkakravchenko
17.04.2023 01:42 •  Информатика

Написать программу на c++, которая обрабатывает введенную строку и выставляет все буквы в алфавитном порядке, например ввод: input example вывод: aeilmnptux

Ответ:
flaming1337
flaming1337
10.10.2020 10:09

#include <iostream>

#include <string>

#include <windows.h>   // для русских букв, можно удалить

using namespace std;

int main()

{

 string s, ss = "";

 int i, l, imin;

 setlocale(LC_ALL, "Russian");

 SetConsoleCP(1251);         // для русских букв, можно удалить

 SetConsoleOutputCP(1251);   // для русских букв, можно удалить

 cout << "Введите строку: ";

 getline (cin, s);

 while (s != "") {

   l = s.length();

   imin = 0;

   for (i = 0; i < l; i++) {

     if (s[i] < s[imin]) {

       imin = i;

     }

   }

   ss = ss + s[imin];

   s.erase(imin, 1);

 }

 cout << "\nРезультат: " << ss << "\n";

}

Объяснение:

если русские буквы не нужны можно удалить операторы с соответствующими комментариями

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?