В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
marysyalabetska
marysyalabetska
30.10.2021 03:30 •  Информатика

Написать программу на языке с++, которая вычисляет произведение отрицательных чисел среди четырех заданных. после чего сообщает - является ли полученное произведение отрицательным или положительным

Ответ:
sasha3637
sasha3637
10.10.2020 08:41

#include <iostream>

using namespace std;

int main()

{

 int a[4];

 int i, p;

 setlocale(LC_ALL, "russian");

 cout << "Введите четыре числа: ";

 for (i = 0; i < 4; i++) {

   cin >> a[i];

 }

 p = 1;

 for (i = 0; i < 4; i++) {

   p *= a[i];

 }

 if (p > 0)

   cout << "\nПроизведение положительно";

 else if (p < 0)

   cout << "\nПроизведение отрицательно";

 else

   cout << "\nПроизведение равно 0";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?