В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
тигрица086
тигрица086
19.09.2022 11:57 •  Информатика

Даны натуральные числа k и n. составить программу формирования массива а, элементами которого являются числа, сумма цифр которых равна k и которые не больше n.
составить программу на паскале.

Ответ:
kukovofiwi342
kukovofiwi342
05.08.2020 08:29

uses crt;

type arr=array[1..1000]of integer;

 

var N, K, C: integer;

a : arr;

 

function sum(n:integer):integer;

var s:integer;

begin

s:=0;

while n<>0 do

begin

 s:=s+n mod 10;

 n:=n div 10;

end;

sum:=s;

end;

 

procedure fill(var a:arr, C, N, K: integer);

var i:integer;

begin

c:=0;

for i:=1 to N do if sum(i)=k then

begin

 inc(c);

 a[c]:=i;

end;

end;

 

begin

clrscr;

write('N K-> ');

readln(N, K);

fill(a, c, N, K);

for i:=1 to с do write(a[i],' ');

readln;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?