В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
СаняDots
СаняDots
25.10.2022 20:46 •  Информатика

Написать программу на языке !
1)дан текст. определите количество цифр в нем.
2)вывести на экран числа в виде следующей таблицы:
41 42 50
51 52 60
61 62 70
71 72 80
3)дан текст, в котором имеются цифры. найдите их сумму.
тема: вложенные циклы​​

Ответ:
23.08.2020 01:13

1)

program test1;

var a:string;

i,n,f:integer;

begin

read (a);

n:=length(a);

for i:=1 to n do begin

if (a[i]>='0') and (a[i]<='9')  

 then f:=f+1;

end;

write ('Количество цифр= ',f);

end.

2)

program test1;

var i:integer;

begin

for i:=41 to 50 do

write(i:3);

writeln;

for i:=51 to 60 do

write(i:3);

writeln;

for i:=61 to 70 do

write(i:3);

writeln;

for i:=71 to 80 do

write(i:3);

end.

3)

var s: string;

   i: byte;

   sum,c,k: integer;

begin

sum:=0;

read(s);

for i:=1 to length(s) do

   if s[i] in ['0'..'9'] then

      begin

      val(s[i],c,k);      

      sum:=sum+c;

      end;

writeln('Сумма цифр=',sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?