В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sasha322322
sasha322322
25.10.2020 10:24 •  Информатика

40 ! нужно, , ! написать программу паскаль. вводится х. вывести у
y=\frac{\sqrt{x^{2}+4+2} }{2}

Ответ:
belka1006
belka1006
10.10.2020 07:11

program Calc;

var

 x, y, z: Real;

begin

 Write ('Введите x: ');

 ReadLn (x);

 z := Sqr (x) + 4 + 2;

 if z > 0 then begin

   y := Sqrt (z) / 2;

   WriteLn ('y = ', y :10 :5);

 end else

   WriteLn ('Значение не определено');

 ReadLn;

end.

Объяснение:

возможно "4" забыли на "x" умножить, тогда замените:

 z := Sqr (x) + 4 * x + 2;

0,0(0 оценок)
Ответ:
Vkomarova
Vkomarova
10.10.2020 07:11

var x: real;

begin

write('x=');

readln(x);

write('y=',sqrt(x*x+4+2)/2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?